Error during upgrade to v9 (from v8)

  • 2 Replies
  • 127 Views

0 Members and 1 Guest are viewing this topic.

*

Offline peldah

  • Newbie
  • *
  • 1
  • 0
Error during upgrade to v9 (from v8)
« on: March 25, 2022, 09:31:58 AM »
Hi,
I am trying to upgrade to latest MagicInfo (21.1010.2)
But during upgrade I recieve error message:

Migration V211010.0__Update.sql failed
--------------------------------------
SQL State  : 23502
Error Code : 0
Message    : FEL: kolumn "organization_id" innehåller null-värden
Location   : C:\MagicInfo Premium\flyway\sql_postgres\V211010.0__Update.sql (C:\MagicInfo Premium\flyway\sql_postgres\V211010.0__Update.sql)
Line       : 3
Statement  : -- [V9 RC #17] Dashboard Device Status info by ORG
ALTER TABLE MI_STATISTICS_CONNECT_HOUR ADD COLUMN ORGANIZATION_ID DECIMAL(10, 0) NOT NULL

I should be able to change that value before the upgrade maybe? Or does it try to add a table and maybe my db-server need a change?
I am not that familiar with DB.

Anyone have a solution for this?

Br, Pelle

*

Offline Pepijn

  • SuperHero & MegaGuru
  • ******
  • 143
  • 87
Re: Error during upgrade to v9 (from v8)
« Reply #1 on: April 15, 2022, 01:08:26 PM »
Dear Pelle,

Indeed V9 will add an extra table.

Most likely the update cannot connect to your database because of the encrypted credentials in the config file.
This will take some effort to adjust, perhaps you can get in contact with a local MagicINFO support party or try to fresh install MagicINFO V9.

Kind regards Pepijn.

*

Offline rgonzalez

  • Newbie
  • *
  • 4
  • 0
Re: Error during upgrade to v9 (from v8)
« Reply #2 on: April 27, 2022, 05:59:31 PM »
Hello Pelle,
I'm having the same issue, did you solve it?
Thank you