Database upgrade error

  • 2 Replies
  • 935 Views

0 Members and 1 Guest are viewing this topic.

*

Offline michael.kristaly

  • Newbie
  • *
  • 1
  • 0
Database upgrade error
« on: August 15, 2023, 02:57:45 PM »
hey all, first time trying to upgrade magicinfo to V9

could not upgrade the db inthe magicinfo seerver installer (db and was are on same box)

when trying to upgrade via http://localhost:8080 as prompted im getting this error

Migration V211000.0__Update.sql failed
--------------------------------------
SQL State  : 42601
Error Code : 0
Message    : ERROR: syntax error at or near "ON"
  Position: 122
Location   : C:\MagicInfo Premium\flyway\sql_postgres\V211000.0__Update.sql (C:\MagicInfo Premium\flyway\sql_postgres\V211000.0__Update.sql)
Line       : 68
Statement  : INSERT INTO MI_CMS_MAP_FILE ( MEDIA_TYPE, FILE_TYPE, DEVICE_TYPE, DEVICE_TYPE_VERSION) VALUES('DLK','DLK','SPLAYER',9.0) ON CONFLICT ON CONSTRAINT mi_cms_map_file_pkey DO NOTHING

anyone got any idea how or why it is happening, and how to resolve it

*

Offline WP_User

  • Newbie
  • *
  • 1
  • 0
Re: Database upgrade error
« Reply #1 on: November 13, 2023, 06:29:58 AM »
Hey all

I came across this Post from Michael when I had the same issue.
I guess I figured out what the root of the issue:
We used Postgres 9.3, but you must use at least Postgres 9.6 for the v9 magicinfo server.
Sadly, the software doesn't check if the Postgres version is right before update...


*

Offline Pepijn

  • SuperHero & MegaGuru
  • ******
  • 182
  • 88
Re: Database upgrade error
« Reply #2 on: June 25, 2024, 03:15:19 PM »
Hi Michael and WP_User,

Indeed for Magicinfo V9 you at least need PostgreSQL V9.6 or V12.

You can create a backup from your current DB, and remove the current PostgreSQL installation. Then install V9.6 or V12 and import the backup in here again.

Samsung also has some info available on their manual.
https://docs.samsungvx.com/docs/pages/viewpage.action?pageId=60035921

Kind regards, Pepijn.