Magicinfo V8 with MS SQL 2016 Express SP3

  • 0 Replies
  • 1271 Views

0 Members and 1 Guest are viewing this topic.

*

Offline guy4732

  • Newbie
  • *
  • 1
  • 0
Magicinfo V8 with MS SQL 2016 Express SP3
« on: January 13, 2023, 05:56:26 PM »
Hey,

Wondering if you guys are able to help out, just having random problems setting up the server using ms sql express 2016 with Service pack 3.

So i'll mention what I do in the process to install MI with MS SQLE and someone let me know if I missed anything or incorrectly set it up.

1: Download SQL 2016 express SP3 & Smss & MI V8

2: Install SQL server basic default installation

3:Enable TCP IP in sql configuration, and named pipes, change TCP IP ports from dynamic to whatever number you decide

4:open SMSS & change sql authentication to windows & sql

5:Restart PC

6: Install MI V8

7: Select MS SQL for the database and give it the password

8: Go to the Magicinfo Premium install folder, go to mssql and run those scripts to create a database, user & tables

9: Restart PC & start magicinfo(Go to its website, service should automatically start within 5min of pc booting.


So, Once i do all of this, I go to magicinfo website to sign into the admin account and add licenses, BUT It tells me wrong password. I checked the MSIINformation txt file created during installation which HAS THE PASSWORD WRITTEN, And it doesnt work. It either says an error has occured OR invalid password on anything. I've tried manually changing the passwords in the sql server ( I verified that the table was created, User is created, Database is created).

You can also change the password in the database, please find the following table
Database>magicinfo>Schemas>Public>Tables>mi_user_info_user

If you change the password details here in: $2a$10$QOrOX5IOGdQ75nv4LqWigeWA35MOLHf8NszMhl2.UfWlriNdnnAp6

That specific user will have the following password: Axk7ALQkg6


Still doesnt work. And best part is, there is no documentation on how to troubleshoot anything related to DB for MI, The installation instructions are basically everything I mentioned above.

And if I check the Conf.properties file in the conf folder in the installation directory, it says this for the wsrm connection... wtf?
wsrm.url=jdbc:postgresql://192.168.0.245:1433//192.168.0.245:1433//;serverName=magicinfo\\MSSQLSERVER;port=;databaseName=magicinfo


What is this? Why is it defaulting to using postgresql to connect to my ms sql server? Obviously not going to work as postgre is NOT installed on the server?

if i go to the magicinfoconfig editor app, (Run as admin) it says the DB port is 1...... and the IP is 0.0.0.0. I have tried setting up MI with MS SQL using MI v6, v5, v7, v8, v9 NONE of them work. Everytime I set everything up and it doesnt work, I simply format the PC and start over from fresh, Reinstall windows and then the sql and MI. Like, What am I missing. The SQL server and MI are sitting on the same pc...... Its connecting to Localhost...... I can open CMD and do the SQLCMD command to connect to the server, I'm in the database, I can also connect to the database using the magicinfo account from a remote computer.... But magicinfo cant seem to do anything. This is some of the worst software i have ever had the pleasure of working with. And i am not paying 500 euro;s for someone to install this for me. Its not  a hard task to do, it just needs better documentation on the process. because there is SOMETHING they didnt add which is required for functionality. Explain why after a fresh install it uses postgresql to connect to my microsoft sql server...................... I've done this installation at least 10 times within the last 3 days.