New V9 Installation - Displays won't connect with server + TLS hickup

  • 4 Replies
  • 1201 Views

0 Members and 1 Guest are viewing this topic.

*

Offline Cillian

  • Newbie
  • *
  • 4
  • 0
Hi everyone,
We've been using 4 Displays with v8 Lite Server inhouse for about a year now without any problems. Server and Displays were within the same closed network.
However, we wanted to deploy the server in our IT center, which can't be connected to the same network as the displays. We deployed a v8 Server with premium licences without any problems, got our firewall configured by a professional and it passed all testing - Displays connected via internet and TLS. Before we'd finally switched all displays to the new server we wanted to "upgrade" to v9. We unhooked the licenses as in the manual, uninstalled magicinfo and postgres and installed the new one. So far, everything went smooth.
Using the non encrypted login on Port 7001 we can use it as expected, but we are only allowed to use the unencrypted trafic within our ITs network. On our site we're only allowed to use the encrypted login on Port 7002. No matter what PC, no matter what browser, we'll get frequent certificate errors because of self signing. The server puts out new certificated every 4 hours, so we can't even permanently allow the certs on the webclients. We didn't have this problem with v8 Server. Is there anything misconfigured or is this expected behaviour and we need to buy SSL Certificated our own for this server?

Next, much bigger problem is that we can't connect any display nor an iPlayer to the server via the internet. Firewall rules are exactly the same as in the working v8 config.
Is there anything new wo configure in v9 the we missed?

Thanks in advance and kind regards,
Cillian

*

Offline Cillian

  • Newbie
  • *
  • 4
  • 0
Re: New V9 Installation - Displays won't connect with server + TLS hickup
« Reply #1 on: April 26, 2023, 12:59:48 PM »
I forgot: we activated the display licences on the new server successfully and don't see any display in the unapproved list. The are 4 Unified players available and 4 unallocated

*

Offline Pepijn

  • SuperHero & MegaGuru
  • ******
  • 182
  • 88
Dear Cillian,

Please be aware that Magicinfo needs to use specific certificates, perhaps you can ask your local distributor what Magicinfo supports
Magicinfo needs a self-signed certificate.

To your knowledge, V8 and V9 are similar in use with the certificates.

Kind regards,
Pepijn.

*

Offline Cillian

  • Newbie
  • *
  • 4
  • 0
OK, thanks for that reply.
However, somehow a fresh install of V8 and a fresh install of V9 seem to behave totally different regarding standard certificates. Anyone knows what's wrong regarding this?

*

Offline Cillian

  • Newbie
  • *
  • 4
  • 0
IT found the solution: the firewall couldn't decrypt the encrypted traffic because the self signing certificates and blocked it. Admin made a new rule for MagicInfo traffic and it's working.