MagicInfo HTTP service not running? Blame your AV.

  • 1 Replies
  • 3574 Views

0 Members and 1 Guest are viewing this topic.

*

Offline BDery

  • Newbie
  • *
  • 1
  • 1
MagicInfo HTTP service not running? Blame your AV.
« on: July 27, 2012, 05:44:01 PM »
I couldn't get the MagicInfo-i Premium Server service to start *at all* (Automatic or Manual) on my Windows 7 Pro machine.

I solved my problem, though.

Quote
1. Uninstall MIIP Server.
2. Control Panel > Add/Remove program : remove PostgreSQL
3. Remove the directory C:\Program Files\Postgres
4. Remove PostgresSQL account from user account if it remains.
5. Remove registry key : HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\pgsql-8.3

6. Uninstall your AV product (and any third-party firewalls. (We use Panda Endpoint Protection)
7. Install Microsoft Security Essentials (optional, if you want it on your server - it works for me)

8. Reboot system.
9. Install MIIP Server new version.

Steps 1-9 (except 6 & 7) are cribbed from 021.MI_TG_Server_Reinstallation_Ver1.00_.pdf, available on samsunglfd.com


Why does this work?

I got the hint from checking details on PostgreSQL on Windows:

https://wiki.postgresql.org/wiki/Running_%26_Installing_PostgreSQL_On_Native_Windows

Quote
What Anti-Virus software is compatible?

The systems used to build the Windows installers all run either Sophos AV or AVG Free Edition, and those systems pass a full set of PostgreSQL regression tests running those programs. Microsoft Security Essentials is also known to work.

Specific issues have been reported with the nod32 antivirus product. If you are using this product, add "postmaster.exe" to the list of excluded processes (available under advanced options). This has been reported to fix the problem.

Specific issues have also been reported with McAfee and Panda anti-virus software and NetLimiter network monitoring software. While some people do have PostgreSQL working with these software packages, there is no specific or even recommend solutions that have not worked in some cases, so the issues would appear to be installation specific, sometimes even requiring uninstallation.

DIGITAL SIGNAGE HELP AND SUPPORT

MagicInfo HTTP service not running? Blame your AV.
« on: July 27, 2012, 05:44:01 PM »

*

Offline EricL

  • Moderator
  • SuperHero & MegaGuru
  • *****
  • 294
  • 41
Re: MagicInfo HTTP service not running? Blame your AV.
« Reply #1 on: July 28, 2012, 05:02:30 PM »
Hi BDery

welcome and thanks for sharing  ;D

Best

EricL