http 500 error first time install etc MagicInfo Premium {SOLVED}

  • 0 Replies
  • 193 Views

0 Members and 1 Guest are viewing this topic.

*

Offline crose

  • Newbie
  • *
  • 1
  • 2
I've been banging my head against the wall for the past few hours trying to solve this.
OS: server 2012-r2
db: postgres 9.3.8.1
MagicInfo Server 6002

Anyways, i installed the db first, then installed the magicinfo server. I didn't use the Express Setup.

When first trying to login, I got the obnoxious "oops sorry the page you tried cannot be found" error, which turns out to be an 500 error code. I checked everything and it was all working as it should: sql server was running and restarted cleanly, same with the magicinfo service, the webpage for the login loaded fine, etc.

After a log of digging on this forum i found someone mention the MagicInfo Premium\runtime\logs directory. There i found the wsrm.log which was complaining about "FATAL: password authentication failed for user "magicinfo"". This was weird, I had only entered in the authentication for the user "magicinfo" during the installer? I didn't use the express settings, so the password wasn't midb2016!. Looking into the pgadmin console, i looked for the magicinfo user. LOW WHAT DID I FIND. The password i entered into the installer was there, but missing the last character (a '%'). WHY WAS THIS you may ask; this installer clearly isn't sanitizing inputs. Wow absolutely brilliant.


Moral of the story: if you aren't using the express install option, when setting up the magicinfo DB password DON'T use a character that postgresql will think is a command!

DIGITAL SIGNAGE HELP AND SUPPORT