Cannot Install Magic Info I

  • 25 Replies
  • 25179 Views

0 Members and 3 Guests are viewing this topic.

*

Offline p2master

  • Newbie
  • *
  • 12
  • 2
Cannot Install Magic Info I
« on: November 25, 2009, 02:37:53 PM »
Please advise:

I have installed PostgreSQL 8.3, and then the MII Server numerous times and it still will not connect. Am I missing a step?  Can someone point me in the direction of the installation manual?  Because I have tried everything to get this to work on two different computers.  It really shouldn't be this hard, but the services aren't starting up correctly and the database doesnt automatically connect so I know something is wrong here.  I also tried PostgreSQL 8.4 before this.  If anyone can help that'd be great.  Thanks in advance

DIGITAL SIGNAGE HELP AND SUPPORT

Cannot Install Magic Info I
« on: November 25, 2009, 02:37:53 PM »

*

Offline Burek1978

  • Newbie
  • *
  • 7
  • 2
Re: Cannot Install Magic Info I
« Reply #1 on: December 02, 2009, 11:55:06 AM »
I had a similar problem with starting the services and I've found a strange work around that might be worth trying.

on the server open up the services and scroll down to the PostgreSQL Database service.

Also goto Start, Programs, MagicInfo-I, Server and open configure MagicInfo-I server.

Now here comes the fun part.

Start the PostrgreSQL service and then impediantly Click start on the MagicInfo-I Service.  It may take a few trys but eventually I got the MagicInfo Service running.  I don;t know why this works and it's a pain as it needs to be done each time the server is restarted. 

let me know how you get on.   :)

*

Offline p2master

  • Newbie
  • *
  • 12
  • 2
Re: Cannot Install Magic Info I
« Reply #2 on: December 02, 2009, 01:28:51 PM »
Thanks for the reply, I was starting to feel on and an island with this thing.

I tried what you said to no avail.  When I click start on the Magic Info I server config, nothing happens.  When I try to start it in the Services window, I get this error:

"Could not start the Magic Info I Server service on Local Computer   ERROR 1075: The dependency service does not exist or has been marked for deletion."

It looks like it's looking for a service called pgsql-8.3, which doesn't exist.  I have uninstalled everything, reinstalled, and tried on 3 different machines.  I am at a stand still here, anything else you could think of?  Has anyone else gotten this error?  Thanks

Adam

*

Offline Burek1978

  • Newbie
  • *
  • 7
  • 2
Re: Cannot Install Magic Info I
« Reply #3 on: December 02, 2009, 02:13:32 PM »
Have you installed PostgreSQL from the MagicInfo Install or downloaded it directly?

I only ask because I had a few issues until I installed it seperately.  There doesn't seem to be any proper linking going on between Post and magicinfo.  there should definately be a PostGreSQL service.  FYI Im running version 8.3 as well.  I'm also running MagicInfo-I version 1004.  I know ther are a few people running 1005 but after this issues I've had I'm not to sure about upgrading.

DIGITAL SIGNAGE HELP AND SUPPORT

Re: Cannot Install Magic Info I
« Reply #3 on: December 02, 2009, 02:13:32 PM »

*

Offline p2master

  • Newbie
  • *
  • 12
  • 2
Re: Cannot Install Magic Info I
« Reply #4 on: December 02, 2009, 03:20:17 PM »
I downloaded PostgreSQL seperately.  I do have a service for it but it's called postgresql server8.3 not pgsql-8.3 or whatever it is looking for.  I'm stumped, I'd really like to get this working so I can test it, and I can't believe more people aren't having this issue.  Also I can't find any documentation on how to install PostgreSQL and test it properly.  Samsung just assumes you have it already and know how to use it.  I'm fed up with the lousy documentation.  I have the install manual, but that tells you virtually nothing about actually installing it. 

*

Offline Scott

  • Newbie
  • *
  • 11
  • 1
Re: Cannot Install Magic Info I
« Reply #5 on: December 02, 2009, 03:54:24 PM »
postgres should come along with the installation package for the server, no need to go get it yourself.  Also it ought to work out of the box, no need to really mess with the configs.  And apache is installed as a service called "magicinfo".  Do be sure to check the firewall between the server and client machine though.

*

Offline p2master

  • Newbie
  • *
  • 12
  • 2
Re: Cannot Install Magic Info I
« Reply #6 on: December 02, 2009, 04:27:57 PM »
Thanks Scott,

Could you link me to the install that you used?  The one I used did not come with PostgreSQL.  It just assumes you have it installed

*

Offline p2master

  • Newbie
  • *
  • 12
  • 2
Re: Cannot Install Magic Info I
« Reply #7 on: December 02, 2009, 04:31:33 PM »
P.S. Firewall is disabled on both machines while testing.

*

Offline Burek1978

  • Newbie
  • *
  • 7
  • 2
Re: Cannot Install Magic Info I
« Reply #8 on: December 04, 2009, 08:41:06 AM »
What operating system are you installing it on?  I had a lot of trouble trying to get it installed on windows 2003 Server x64.  Just a thought.

DIGITAL SIGNAGE HELP AND SUPPORT

Re: Cannot Install Magic Info I
« Reply #8 on: December 04, 2009, 08:41:06 AM »

*

Offline p2master

  • Newbie
  • *
  • 12
  • 2
Re: Cannot Install Magic Info I
« Reply #9 on: December 04, 2009, 05:04:06 PM »
I'm just using Windows XP as a test. It says it's compatible