Magic Info Server + Postgres

  • 3 Replies
  • 5240 Views

0 Members and 3 Guests are viewing this topic.

*

Offline BeHeaven616

  • Newbie
  • *
  • 4
  • 0
Magic Info Server + Postgres
« on: May 14, 2018, 08:41:22 AM »
Hello!

I recently tried to install magic info Server v. 4101-8 but i am stuck at an error 500 message after logging into magic info web interface.

i installed postgresql-10.3-3-windows-x64.exe and set a password for the db, then i opened up the magic info server setup, chose postgres (express/ Full/ http) hit next and dial in the postgres Password. After the installation was complete i made sure the magic info services were running.

The next step was opening the web interface with http://localhost:7001/MagicInfo
The web interface opens up fast, i try to log in with the admin user and pw, and then i get the oops, error 500 message.

Do i miss any installation steps? my native language is german and all the user manuals i find online are english/ chinese so they are not very helpful. Also i cant find any tutorials online on how to set up everything properly.

i also need to say that i try installing the software on a company notebook, the login process also happens on the same device.



Oh and i have a question by the way: The point of installing magic info for us is to get a samsung SBB-SS08EL1/EN working for a video wall in our company. the display should show a website with java components, but we dont know if thats even possible!!



Thank you for your help and greetings from austria!

*

Offline Pepijn

  • SuperHero & MegaGuru
  • ******
  • 91
  • 63
Re: Magic Info Server + Postgres
« Reply #1 on: May 14, 2018, 12:13:25 PM »
Hello,

You could look in the log files to see what is going on.

You can find the log file:
C:\MagicInfo Premium\tomcat\logs
in localhost.*.log
or
C:\MagicInfo Premium\runtime\logs

Kind regards,
Pepijn.

*

Offline BeHeaven616

  • Newbie
  • *
  • 4
  • 0
Re: Magic Info Server + Postgres
« Reply #2 on: May 15, 2018, 11:52:39 AM »
okay i will post the error codes as soon as i get magicinfo setup done again.
May someone consider helping me whith that?

I run into the following problem: So my coworker gave me the advice to install an older version of psotgres due to compatibility issues to our network.

i uninstalled both, magicinfo and postgres, deleted all of the remaining folders on my harddrive and the restartet my machine. after installing postgres with pgadmin console and setting a pw i took another step and tried to install magicinfo again. Now when i have to dial in the pg password i get an error "check db password".


For all my tries to get this system running i always used the same pg password. now, what password ever i set in pg, magic info wont take it!


any ideas?

*

Offline Maciej

  • Newbie
  • *
  • 3
  • 0
Re: Magic Info Server + Postgres
« Reply #3 on: May 18, 2018, 02:25:56 PM »
I had to install postgres 9.3.8-1 64bit to make it work, older version would throw error 500 saying db doesn't exist, with this version they've gone away with creating a local user to access the database which might've been the cause of issues. That's with java 7.25 installed, install was just next until finish and worked fine since