Magicinfo i Premium, Unable to Upload Videos, Only PPTx

  • 2 Replies
  • 5261 Views

0 Members and 1 Guest are viewing this topic.

*

Offline whitIT

  • Newbie
  • *
  • 3
  • 0
Magicinfo i Premium, Unable to Upload Videos, Only PPTx
« on: November 23, 2011, 03:53:58 PM »
Hi All,

we have version 1008 installed at present and i cant upload videos or any sort (mpg, wmv or avi). when i try to upload videos via the samsung upload manager i get the following errors in the Java Debugging Console.


getVideoFileMeta strCommand="c:\program files\ContentUploader\ffmpeg.exe" -i "\\server\videotest.WMV"
Exception in thread "Thread-12" java.lang.ArrayIndexOutOfBoundsException: 1
   at com.samsung.magicinfo.uploader.common.Common.getFileMeta(Common.java:616)
   at com.samsung.magicinfo.uploader.common.Common.createThumbnailFile(Common.java:510)
   at com.samsung.magicinfo.uploader.adapter.ButtonAdapter$4.run(ButtonAdapter.java:720)
   at java.lang.Thread.run(Unknown Source)


does anybody have any ideas?





thanks,
 ;D ;D ;D


DIGITAL SIGNAGE HELP AND SUPPORT

Magicinfo i Premium, Unable to Upload Videos, Only PPTx
« on: November 23, 2011, 03:53:58 PM »

*

Offline AGrice

  • Newbie
  • *
  • 2
  • 0
Re: Magicinfo i Premium, Unable to Upload Videos, Only PPTx
« Reply #1 on: July 31, 2012, 12:41:12 PM »
Post 1 of 2 (due to 2000 character limit per post)

Hi All,

This had been causing ongoing problems for our users.  After many hours (days) of testing, reinstalling Java, reinstalling Java, reinstalling Java and reinstalling Java it turns out to be nothing to do with Java.  After not hearing anything back from SAMSUNG support I worked out the following.

The problem of uploading videos is due to FFMPEG.EXE.  Although the Java 7 u 4 messed up and it took an OS rebuild to solve it, (maybe that is a post for www.java.com not www.signagehelp.com.)  Anyway this FFMPEG.EXE is normally created along with some other files and folders in %userprofile%.  These files are auto created @ this location when you click 'Content --> Add', include this FFMPEG.EXE.

In my case, on a none redirected PC, this is C:\Documents and Settings\user.  If you are redirecting user folders via GPOs on a domain network please be aware that this file/folder set that is created may be created elsewhere (normally near the redirected location).  This location will need right access for the user (group) doing the operation, which should be OK for the normal location but if you are redirecting, you will need to check permissions at this location.

Continued...


*

Offline AGrice

  • Newbie
  • *
  • 2
  • 0
Re: Magicinfo i Premium, Unable to Upload Videos, Only PPTx
« Reply #2 on: July 31, 2012, 12:57:00 PM »
Post 2 of 2 (due to 2000 character limit per post)

Either way the FFMPEG.EXE that is auto created does not successfully uploaded videos and you will be a 1056 error.  I don’t now where is came from but I found a larger FFMPEG.EXE on our network and once you replace the FFMPEG.EXE with this other larger version it uploads these files perfectly. If you need a copy of this version that works let me know via this page.  As I have email notifications turned on with this topic I should get the message and be able to send the exe that works.  You might be able to download this from somewhere else.

The last thing that I haven’t been able to solve is where these files that are auto created, after clicking 'Content --> Add', come from.  I think they must come from the server. If I knew this I could update the FFMPEG.EXE at this location.  If anyone else has any further ideas I would be most interested to hear them as this has taken me 10s of hours to come to these conclusions.

Please update this topic to say if this worked for you or helped in anyway.

Many thanks

Adam